cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Contributor

Adtran 900e - Inbound SIP DID to FX0 and overflow to PRI

First post and new to Adtran so please forgive ignorance.

I have successfully configured our 924e to accept inbound DID SIP calls from our telco provider and hand them off to a PRI (that terminates into an ACD).  I have managed to assign some FX0 ports on the Adtran to have their own DID (setting the FXO extension number to actually be the DID) so that inbound SIP calls to those specific DID's ring the POTS phones.  However I have not been able to get "Call Coverage" to work so that if the POTS lines are not answered in 2 rings, the call is sent to a different number that routes down our PRI into the ACD.

My first biggest challenge was when going off hook on the POTS lines, to have the ADTRAN send the call over our SIP connection - by default it was always sending the call to our ACD over the PRI.  I had some help and managed to get the outbound POTS calls to go out our SIP lines by using "Least Cost Routing".  I am wondering if that is what is breaking the Call Coverage now.  Fiddling around I was able to get "Operator Assisted Calls" from the POTS to go to the PRI instead of over the SIP lines.  So on the POTS if I go off hook and dial a 10 digit number prefaced with a Zero, the call goes to the PRI - If I just dial a 10 digit number on its own, it goes out our SIP lines - which should work alright.  However when I put the 11 digit number (0-123-456-7890) into Call Coverage section of my extension, and make a test call - the extension rings twice and then goes to a busy.

Any help would be much appreciated.  If there are videos out there explaining how the Adtran 900e processes calls, that would really help too.  I've no doubt I'm missing a core concept or two on how these Classes of Service and Dial Plans all tie in with the different inbound/outbound call matrices.

Thanks in advance,

Mark.

Labels (3)
0 Kudos
2 Replies
Highlighted
Valued Contributor
Valued Contributor

Re: Adtran 900e - Inbound SIP DID to FX0 and overflow to PRI

Hi,

Checkout this document Source and ANI Based Routing in AOS Voice Products

If post your config I should be able to give more direction.

Thank you

Highlighted
New Contributor

Re: Adtran 900e - Inbound SIP DID to FX0 and overflow to PRI

Wow that was fast, thanks Unified!  I actually found that document while doing all my research but with my limited understanding in how it all ties together, it was a bit over my head.  I edited my config a bit for security's sake but the 1112223333 is my DID that comes in from the SIP carrier to the Adtran and rings the FX0 port.  The 04445556666 number is my 'operator assisted' number that I would like the Adtran to ring to when the DID is not answered on the FX0 port - I am using call coverage for that.  There may be a much better way to do this....

!

!

! ADTRAN, Inc. OS version R13.5.2.E

! Boot ROM version R10.9.3.B3

! Platform: Total Access 900e (3rd Gen), part number 4243924F1

! Serial number

!

!

hostname "924e01"

enable password encrypted password

!

!

clock timezone -5-Eastern-Time

!

ip subnet-zero

ip classless

ip routing

ipv6 unicast-routing

!

!

name-server 8.8.8.8 8.8.4.4

!

!

auto-config

auto-config authname adtran encrypted password password

!

event-history on

no logging forwarding

no logging email

!

service password-encryption

!

username "user" password encrypted "password"

!

banner motd #

This attempt has been reported. #

!

!

ip firewall

ip firewall stealth

no ip firewall alg msn

no ip firewall alg mszone

no ip firewall alg h323

!

!

!

!

!

!

!

!

no dot11ap access-point-control

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface eth 0/1

  description VENDOR1

  ip address  VENDOR IP/SUBNET

  ip mtu 1500

  ip access-policy Public

  no shutdown

  media-gateway ip primary

!

!

interface eth 0/2

  description VENDOR2

  ip address  VENDOR IP/SUBNET

  ip access-policy Public

  no shutdown

  media-gateway ip primary

!

!

!

interface gigabit-eth 0/1

  ip address  LAN IP / SUBNET

  ip access-policy Private

  no shutdown

  media-gateway ip primary

!

!

!

!

interface t1 0/1

  description PRI to ACD

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

interface t1 0/2

  description PRI to ACD 2

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

interface t1 0/3

  description PRI to ACD 3

  tdm-group 1 timeslots 1-24 speed 64

  no shutdown

!

interface t1 0/4

  shutdown

!

!

interface pri 1

  description pri 1

  alias 924e01-01

  isdn name-delivery setup

  connect t1 0/1 tdm-group 1

  no shutdown

!

interface pri 2

  description pri 2

  alias PRI 2

  connect t1 0/2 tdm-group 1

  no shutdown

!

interface pri 3

  description pri 3

  alias PRI 3

  connect t1 0/3 tdm-group 1

  no shutdown

!

!

interface fxs 0/1

  no shutdown

!

interface fxs 0/2

  no shutdown

!

interface fxs 0/3

  no shutdown

!

interface fxs 0/4

  no shutdown

!

interface fxs 0/5

  no shutdown

!

interface fxs 0/6

  no shutdown

!

interface fxs 0/7

  no shutdown

!

interface fxs 0/8

  no shutdown

!

interface fxs 0/9

  no shutdown

!

interface fxs 0/10

  no shutdown

!

interface fxs 0/11

  no shutdown

!

interface fxs 0/12

  no shutdown

!

interface fxs 0/13

  no shutdown

!

interface fxs 0/14

  no shutdown

!

interface fxs 0/15

  no shutdown

!

interface fxs 0/16

  no shutdown

!

interface fxs 0/17

  no shutdown

!

interface fxs 0/18

  no shutdown

!

interface fxs 0/19

  no shutdown

!

interface fxs 0/20

  no shutdown

!

interface fxs 0/21

  no shutdown

!

interface fxs 0/22

  no shutdown

!

interface fxs 0/23

  no shutdown

!

interface fxs 0/24

  no shutdown

!

!

isdn-group 1

  connect pri 1

!

!

isdn-group 2

  connect pri 3

!

!

isdn-group 3

  connect pri 2

!

!

!

!

timing-source t1 0/1

!

!

!

!

ip access-list extended VoiceLink

  permit ip LAN  any     log

!

ip access-list extended web-acl-6

  remark ThinQ Primary IP

  permit ip VENDOR1  any   

!

ip access-list extended web-acl-7

  remark ThinQ Second IP

  permit ip VENDOR2  any   

!

!

!

!

ip policy-class Private

  allow list self self

!

ip policy-class Public

  allow list web-acl-6

  allow list web-acl-7

!

!

!

ip route 0.0.0.0 0.0.0.0 VENDOR1

ip route 0.0.0.0 0.0.0.0 VENDOR2

!

no tftp server

no tftp server overwrite

http server

no http secure-server

snmp agent

no ip ftp server

no ip scp server

no ip sntp server

!

!

!

!

snmp-server enable traps

snmp-server community Auvik RW

snmp-server host LAN traps version 2c Auvik

!

!

!

!

sip

sip udp 5060

no sip tcp

no sip tls

!

!

!

voice feature-mode network

voice forward-mode network

!

!

!

!

!

!

!

!

voice dial-plan 2 local NXX-NXX-XXXX

!

!

!

!

voice class-of-service POTS_to_SIP

  call-privilege extensions

  call-privilege international

  call-privilege local

  call-privilege long-distance

  call-privilege operator-assisted

  call-privilege specify-carrier

  call-privilege toll-free

  external-fwd

!

voice codec-list "Codec #1"

  codec g711ulaw

  codec g711alaw

  codec g729

  codec g722

!

!

!

voice trunk T01 type isdn

  description "PRI to ACD"

  resource-selection circular descending

  connect isdn-group 1

  rtp delay-mode adaptive

!

voice trunk T02 type sip

  description "SIP VENDOR"

  sip-server primary SIP VENDOR IP/SUBNET

  registrar primary SIP VENDOR IP/SUBNET

  outbound-proxy primary SIP VENDOR IP/SUBNET

  transfer-mode local

!

voice trunk T03 type isdn

  description "PRI to ACD 2"

  resource-selection circular descending

  connect isdn-group 3

  rtp delay-mode adaptive

!

voice trunk T04 type isdn

  description "PRI to ACD 3"

  resource-selection circular descending

  connect isdn-group 2

  rtp delay-mode adaptive

!

voice trunk T05 type analog supervision loop-start

  description "POTS"

  rtp delay-mode adaptive

!

!

voice grouped-trunk "PRI TO ACD"

  trunk T01

  trunk T03

  trunk T04

  accept NXX-NXX-XXXX cost 400

  accept 1-NXX-NXX-XXXX cost 400

  accept 1-800-NXX-XXXX cost 400

  accept 1-888-NXX-XXXX cost 400

  accept 1-877-NXX-XXXX cost 400

  accept 1-866-NXX-XXXX cost 400

  accept 1-855-NXX-XXXX cost 400

  accept 411 cost 400

  accept 611 cost 400

  accept 911 cost 400

  accept 0-NXX-NXX-XXXX cost 400

  accept 10-10-XXX-$ cost 400

  reject NXX-976-XXXX

  reject 1-900-NXX-XXXX

  reject 1-976-NXX-XXXX

  reject 1-NXX-976-XXXX

!

!

voice grouped-trunk SIP_Vendor_GROUP

  trunk T02

  accept NXX-NXX-XXXX cost 0

  accept 1-NXX-NXX-XXXX cost 0

  accept 1-800-NXX-XXXX cost 0

  accept 1-888-NXX-XXXX cost 0

  accept 1-877-NXX-XXXX cost 0

  accept 1-866-NXX-XXXX cost 0

  accept 1-855-NXX-XXXX cost 0

  accept 011-$ cost 0

  accept 411 cost 0

  accept 611 cost 0

  accept 911 cost 0

  accept 10-10-XXX-$ cost 0

  reject NXX-976-XXXX

  reject 1-900-NXX-XXXX

  reject 1-976-NXX-XXXX

  reject 1-NXX-976-XXXX

!

!

voice grouped-trunk POTS_GROUP

  trunk T05

  accept 0-NXX-NXX-XXXX cost 400

  accept NXX-NXX-XXXX cost 0

  accept 1-NXX-NXX-XXXX cost 0

  reject 1-800-NXX-XXXX

  reject 1-888-NXX-XXXX

  reject 1-877-NXX-XXXX

  reject 1-866-NXX-XXXX

  reject 1-855-NXX-XXXX

  reject NXX-976-XXXX

  reject 1-900-NXX-XXXX

  reject 1-976-NXX-XXXX

  reject 1-NXX-976-XXXX

!

!

voice user 1112223333

  connect fxs 0/1

  cos "POTS_to_SIP"

  first-name "1"

  last-name "Line"

  password encrypted "password"

  description "1112223333"

  caller-id-override external-number 1112223333

  caller-id-override internal-name "Company Name"

  caller-id-override internal-number 1112223333

  num-rings 1

  coverage  external 04445556666

  sip-identity 1112223333 T02

  sip-authentication password encrypted "password"

!

!

!

!

!

!

!

!

!

!

!

!

!

no sip registrar authenticate

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

line con 0

  no login

!

line telnet 0 4

  login local-userlist

  no shutdown

line ssh 0 4

  login local-userlist

  no shutdown

!

!

ntp source gigabit-ethernet 0/1

ntp peer 0.us.pool.ntp.org normal-sync

ntp peer time-a-g.nist.gov normal-sync

!

!

!

end