cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
andrewtre
Contributor
Contributor

Directories not updating

Jump to solution

I have a new installation of a 7100 running VVX 500 phones.  I have added system speed dials to the unit and want to push those out to all the phones.  They are properly being added to the 000000000000-directory.xml file, but when i try to update directories in the GUI, they do not push out to the MAC-directory.xml files.  The files that are updated are actually incomplete.  The new file only contains about half of the system users, and no other entries.  Is this a failure of the GUI?  Is there a console command that will do the same job? 

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Anonymous
Not applicable

Re: Directories not updating

Jump to solution

This is an issue we are aware of and are working on a software fix. As a workaround you can delete the mac-directory.xml file for a particular phone and then rebuilt it to populate the mac-directory.xml file correctly. If it works for one phone, you can use the following procedure to apply this workaround to all Polycom phones:

  • add all the names you want to the global directory and save it
  • issue the erase cflash polycom/*-directory.xml command from enable mode in the CLI to wipe all the mac-directory.xml files
  • in the GUI go to "IP Phone Globals" and save the global directory
  • then go to the "IP Phone Configs" page, select all of the Polycom phones, and go to Other Actions > Update Directories
  • reboot the phones so they will download the new mac-directory.xml files

Thanks,

Matt

View solution in original post

0 Kudos
3 Replies
Anonymous
Not applicable

Re: Directories not updating

Jump to solution

This is an issue we are aware of and are working on a software fix. As a workaround you can delete the mac-directory.xml file for a particular phone and then rebuilt it to populate the mac-directory.xml file correctly. If it works for one phone, you can use the following procedure to apply this workaround to all Polycom phones:

  • add all the names you want to the global directory and save it
  • issue the erase cflash polycom/*-directory.xml command from enable mode in the CLI to wipe all the mac-directory.xml files
  • in the GUI go to "IP Phone Globals" and save the global directory
  • then go to the "IP Phone Configs" page, select all of the Polycom phones, and go to Other Actions > Update Directories
  • reboot the phones so they will download the new mac-directory.xml files

Thanks,

Matt

View solution in original post

0 Kudos
andrewtre
Contributor
Contributor

Re: Directories not updating

Jump to solution

That did it.  Thanks

neonettech
New Contributor

Re: Directories not updating

Jump to solution

Hi,

with the end of life for Flash - is there a cli command to update the polycom phone directories?

Thanks,

Frank